Smooth radial gradient?!

Put problem concerning Views, Layouts and other XML-Resources (like AndroidManifest) here.

Smooth radial gradient?!

Postby Coyle » Sun Aug 30, 2009 9:18 am

Hey,
Since 2 days I'm trying to get my radial gradient smooth but somehow it's not working:

Syntax: [ Download ] [ Hide ]
Using xml Syntax Highlighting
  1. <?xml version="1.0" encoding="utf-8"?>
  2. <layer-list xmlns:android="http://schemas.android.com/apk/res/android">
  3. <item>
  4.         <shape>
  5.                 <gradient android:type="radial"
  6.        android:startColor="#565656"
  7.        android:endColor="#181818"
  8.        android:gradientRadius="300"
  9.        android:centerX="0.5"
  10.        android:centerY="0.5"/>
  11.         </shape>
  12. </item>
  13. <item>
  14.         <bitmap
  15.                 android:src="@drawable/background_scanline"
  16.         android:tileMode="repeat"/>
  17. </item>
  18. </layer-list>
  19.  
Parsed in 0.002 seconds, using GeSHi 1.0.8.4


Result:
Image

I just want to get a background like this:
Image

The annoying part is if I use red as start color and yellow as end color it's smooth but with these colors it's not working.

I hope someone can help me.

Rgds
Coyle
Coyle
Freshman
Freshman
 
Posts: 8
Joined: Sun Aug 30, 2009 9:08 am

Top

Postby Shanytc » Sun Aug 30, 2009 1:30 pm

maybe it's a limitation of the emulator? color range.. ??
- Shany -
Shanytc
Junior Developer
Junior Developer
 
Posts: 17
Joined: Fri Aug 14, 2009 11:00 am

Top

Return to View, Layout & Resource Problems

Who is online

Users browsing this forum: No registered users and 4 guests