R.java is not modifying

Put problem concerning Views, Layouts and other XML-Resources (like AndroidManifest) here.

R.java is not modifying

Postby genxsol » Tue Feb 17, 2009 4:39 pm

Hi,
i want to add a new xml called Login.xml in the Layout section which caused an error because there is no refrence of this file in R.java.

i cant run application and not even update R.java.
please tell me if there is any automatic procedure which update refrences in R.java whenever we add a new screen.
waiting for a quick response


Thanks,
genxsol
Junior Developer
Junior Developer
 
Posts: 11
Joined: Tue Feb 17, 2009 11:24 am

Top

Postby MrSnowflake » Tue Feb 17, 2009 4:42 pm

Eclipse has a menu option: Project -> automatic build. It should be on.
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Postby genxsol » Tue Feb 17, 2009 4:48 pm

thanks for the reply,

Automatic build is already on.
genxsol
Junior Developer
Junior Developer
 
Posts: 11
Joined: Tue Feb 17, 2009 11:24 am

Postby MrSnowflake » Tue Feb 17, 2009 4:53 pm

Then do a clean and remove R.java.
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Postby genxsol » Tue Feb 17, 2009 4:57 pm

yes i did and now how can i create new R.java?
genxsol
Junior Developer
Junior Developer
 
Posts: 11
Joined: Tue Feb 17, 2009 11:24 am

Postby MrSnowflake » Tue Feb 17, 2009 4:58 pm

What does the console/output say?
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Top

Postby genxsol » Tue Feb 17, 2009 5:03 pm

there is error symbol on eclipse project, i cant run it now. i restarted eclipse but same error .
your project contains errors , please fix them before
genxsol
Junior Developer
Junior Developer
 
Posts: 11
Joined: Tue Feb 17, 2009 11:24 am

Postby genxsol » Tue Feb 17, 2009 5:16 pm

i also made a new project say hello world, added a new xml screen in Layout. it still shows error (cross symbol at project name) and cannot build the project.
anyone help me please!
genxsol
Junior Developer
Junior Developer
 
Posts: 11
Joined: Tue Feb 17, 2009 11:24 am

Postby MrSnowflake » Tue Feb 17, 2009 6:32 pm

Then find out what the error is. There must be a file with an error sign somewhere in eclipse.
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Postby genxsol » Tue Feb 17, 2009 10:24 pm

Here we go!
it is fixed. i tried to make a new project again, added xml and it worked.

thanks a lot
genxsol
Junior Developer
Junior Developer
 
Posts: 11
Joined: Tue Feb 17, 2009 11:24 am

Top

Return to View, Layout & Resource Problems

Who is online

Users browsing this forum: No registered users and 7 guests