[solved] Gallery in ListView very slow when not last item

Put problem concerning Views, Layouts and other XML-Resources (like AndroidManifest) here.

[solved] Gallery in ListView very slow when not last item

Postby zarzu » Mon Nov 02, 2009 9:43 pm

hey

i have a problem with a Gallery within a ListView, when it's the last item i put into it, it works perfectly with flinging etc, if i add other items after the Gallery it becomes painfully slow and doesn't even finish it's animations, if i add a second Gallery at the end, the one at the end will work fine, the first one not.
this seems to me like only one item in the ListView actually fully performs and all the others take a backseat or something, but i have no clue what exactly is going on and how to possibly change this.

any help is appreciated, thanks.


/edit: i can work around this by making multiple lists in sequence such that the gallery is at the bottom of one, but that is really ugly and i don't like to do it.
zarzu
Freshman
Freshman
 
Posts: 7
Joined: Mon Nov 02, 2009 9:38 pm

Top

Postby zarzu » Sun Nov 08, 2009 9:49 pm

i ran into more and more problems like this when i continued, adding and removing items in a gallery lead to the same slowing down, so do different redrawings of bitmaps etc. in the end i just took the gallery out of the list which makes everything work fine. conclusion: don't ever put a gallery in a listview.
zarzu
Freshman
Freshman
 
Posts: 7
Joined: Mon Nov 02, 2009 9:38 pm

Top

Return to View, Layout & Resource Problems

Who is online

Users browsing this forum: No registered users and 10 guests