Unable to install ADT-0.9.3 in eclipse

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Unable to install ADT-0.9.3 in eclipse

Postby pravin » Fri Sep 25, 2009 6:34 am

Hi everybody

I have just downloaded the latest ADT-0.9.3 for eclipse. And i have tried it installing on eclipse-ganymede and eclipse-galileo. its giving the below error in both

Cannot complete the request. See the details.
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.core/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gef/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gef/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.core/0.0.0
Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.3.v200909031112-12945] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/0.0.0


I have removed the previous insatlled ADT-0.8.0.
Pls get me out of this problem.
The attached is the ADT-0.9.3 zip file

Thanks
Attachments
ADT-0.9.3.zip
(3.1 MiB) Downloaded 4605 times
pravin
Junior Developer
Junior Developer
 
Posts: 13
Joined: Wed Nov 12, 2008 11:26 am
Location: India

Top

Fix

Postby xplagu3 » Sat Sep 26, 2009 3:51 pm

G'day Champ

I had the same problem:

To fix:

Add http://download.eclipse.org/releases/ganymede/ in the manage sites section
The install ADT plugin as normal


Reference: http://code.google.com/eclipse/docs/faq ... stallerror
xplagu3
Freshman
Freshman
 
Posts: 4
Joined: Sat Sep 26, 2009 3:42 pm

Re: Fix

Postby pravin » Tue Sep 29, 2009 5:27 am

xplagu3 wrote:G'day Champ

I had the same problem:

To fix:

Add http://download.eclipse.org/releases/ganymede/ in the manage sites section
The install ADT plugin as normal


Reference: http://code.google.com/eclipse/docs/faq ... stallerror



Thank you very much for the reply 'xplagu3'. :)
I installed the plugin as per your suggestions.But still i have another problem .The plugins are showing as installed in the Installed Softwares, but when i want to set the android-sdk-1.6 path in the eclipse Preferences its not displaying the Android option to set, its just displaying the DDMS option in it. And also while creating a new project i am unable to get the ANDROID project option. Hence unable to move forward. Pls help me out of this situation.


Regards,
Pravin
pravin
Junior Developer
Junior Developer
 
Posts: 13
Joined: Wed Nov 12, 2008 11:26 am
Location: India

Postby xplagu3 » Tue Sep 29, 2009 8:57 am

In Project -> Properties -> Android it had a browse file field for me I put in /opt/android-sdk-linux_x86-1.6_r1
I have the following installed software
- Android DDMS
- Android Development Tools
- Eclipse SDK
- Google App Engine Java DSK 1.2.5
- Google Plugin for Ecliupse
- Google Web Toolkit SDK

But i think you only need the fist 2 for android projects..

It works for me with no problems after the plugins were installed.

Sorry other than that I don't know. I'm only just learning
xplagu3
Freshman
Freshman
 
Posts: 4
Joined: Sat Sep 26, 2009 3:42 pm

Postby gooey_kablooie » Wed Sep 30, 2009 10:42 am

I am getting a similar problem as that of pravin. I am able to install ADT in eclipse Europa (I am working on Fedora 8). But when I open my preferences page it displays the following error message

Code: Select all
Unable to create the selected preference page.
Reason :
An error occured while automatically activating bundle com.android.ide.eclipse.adt.


Can anyone help me to resolve this issue?

Thanks in advance.
gooey_kablooie
Freshman
Freshman
 
Posts: 2
Joined: Wed Sep 30, 2009 10:31 am
Location: Bangalore, India

Postby jgg » Fri Oct 23, 2009 7:00 am

Hi. I am facing a problem similar to the one mentioned by gooey_kablooie.
I am using Eclipse Ganymede 3.4.2 on Windows.
Any number of re-intallations of Eclipse / ADT plugin do not seem to fix it.

Unable to create the selected preference page.
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException

Unable to create the selected preference page.
An error occurred while automatically activating bundle com.android.ide.eclipse.adt (172).

Does anyone have any pointers on how I can get out of this error?

Thanks.
jgg
Once Poster
Once Poster
 
Posts: 1
Joined: Fri Oct 23, 2009 5:24 am

Top

Postby pravin » Fri Oct 23, 2009 7:29 am

jgg wrote:Hi. I am facing a problem similar to the one mentioned by gooey_kablooie.
I am using Eclipse Ganymede 3.4.2 on Windows.
Any number of re-intallations of Eclipse / ADT plugin do not seem to fix it.

Unable to create the selected preference page.
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException

Unable to create the selected preference page.
An error occurred while automatically activating bundle com.android.ide.eclipse.adt (172).

Does anyone have any pointers on how I can get out of this error?

Thanks.



Hi 'jgg',

Did u tried the solution explained by 'xplagu3' in the discussion?
If not pls try it and reinstall the plugin.
Right now i am using eclipse ganymede jee edition.
It doesn't give any problem and was installed smoothly. :)

Have a Gud Day.
pravin
Junior Developer
Junior Developer
 
Posts: 13
Joined: Wed Nov 12, 2008 11:26 am
Location: India

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 13 guests