"Unable to create the selected preference page"

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

"Unable to create the selected preference page"

Postby crishe » Fri Nov 16, 2007 6:15 pm

Image


Being a beginner at eclipse and obviously android I have no idea what
this is about. I have gone through the steps for installing eclipse /
SDK / Plugin and I don't get any problems or errors until this step.
I hope it's easy to resolve as I'm extremely eager to get some apps
happenin :!:

[Edit]
Adjusted Topic-Title
crishe
Once Poster
Once Poster
 
Posts: 1
Joined: Fri Nov 16, 2007 6:13 pm

Top

Postby plusminus » Fri Nov 16, 2007 6:23 pm

Hey,

this bug can occur, if you try to load with a JRE < 1.5
Check whether your "workspace->.metadata->.log" contains sth like:
"...(Unsupported major.minor version 49.0)..."

Possible Solution:
Go to Project --> Properties --> Java Compiler --> JDK Compiler compliance level (and the others) to at least 5.0

If you cannot select it, then you need to apply it under:
Preferences --> Java --> Installed JREs --> Add...

If you haven't downloaded, so you would need to download a never JDK version.

Regards, plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

thank you very much&#65281;

Postby gandroid » Sat Nov 17, 2007 4:20 pm

i meets same questions。
study google android now!
gandroid
Freshman
Freshman
 
Posts: 2
Joined: Sat Nov 17, 2007 4:11 pm

Re: thank you very much&#65281;

Postby plusminus » Sat Nov 17, 2007 4:58 pm

gandroid wrote:i meets same questions。


Hi,
in order to help you, we will need some information about your setup!
:?: Do you get the exact same error-message?
What OS / JDK and SDK/ADT-Versions are you running?

That would make helping a lot easier :wink:

Regards,
plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

install eclipse europa please

Postby gandroid » Sun Nov 18, 2007 4:46 am

jdk 1.5
eclipse europa for java
study google android now!
gandroid
Freshman
Freshman
 
Posts: 2
Joined: Sat Nov 17, 2007 4:11 pm

Postby plusminus » Sun Nov 18, 2007 7:59 pm

A really dirty workaround would be setting up an Virtual Machine :? ...

Did you try the updated ADT (it's now at version 0.3.1) :?:
Are you using the Sun JRE/JDK :?: (some people got problems using other ones)

You could also try a complete reinstallation of eclipse (I did so, having to much crappy plugins, that made eclipse crash form time to time)
That is not too hard, as the Settings/SVNPassword/Workbench remain...

Regards,
plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

Top

major.minor problem 49

Postby yamenr » Wed Nov 28, 2007 4:37 pm

Hi,

I'm facing the problem too.
I changed the JRE, and now I have JRE 1.5.0_14 - But I'm still having the problem.

Using eclipse:
Eclipse SDK
Version: 3.3.1.1
Build id: M20071023-1652

What can I do else?


Regards,
Yamen
yamenr
Freshman
Freshman
 
Posts: 5
Joined: Wed Nov 28, 2007 4:30 pm
Location: Nazareth - Israel

Postby plusminus » Wed Nov 28, 2007 5:15 pm

Hello yamenr,

did this help :arrow: (click)

Regards,
plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 9 guests