Trouble getting my app started on my android device

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Trouble getting my app started on my android device

Postby sebastian.bueno.a » Fri May 17, 2013 4:02 pm

I had been trying to make an app using Eclipse Juno (), I have no idea abour programming and thats why I was tring to make it using a tutorial from youtube, from an user called "Javier C". I made all what he said, but I cant getting it started on my Android device and this is what my manifest says:

MANIFEST:
Code: Select all
<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http(ignore this)://schemas.android.com/apk/res/android"
    package="com.sebab.mapasvegetarianoschile1"
    android:versionCode="1"
    android:versionName="1.0" >

    <uses-sdk
        android:minSdkVersion="7"
        android:targetSdkVersion="14" />

    <permission
        android:name="com.sebab.mapasvegetarianoschile1.permission.MAPS_RECEIVE"
        android:protectionLevel="signature"/>
   <uses-permission android:name="com.sebab.mapasvegetarianoschile1.permission.MAPS_RECEIVE"/>
   <uses-permission android:name="android.permission.INTERNET"/>
   <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>
   <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/>
   <uses-permission android:name="com.google.android.providers.gsf.permission.READ_GSERVICES"/>
   <!-- The following two permissions are not required to use
        Google Maps Android API v2, but are recommended. -->
   <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION"/>
   <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION"/>
   
   <uses-feature
        android:glEsVersion="0x00020000"
        android:required="true"/>
    <application
        android:allowBackup="true"
        android:icon="@drawable/ic_launcher"
        android:label="@string/app_name"
        android:theme="@style/AppTheme" >
      <meta-data
          android:name="com.google.android.maps.v2.API_KEY"
          android:value="AIzaSyC8NhXNs1vJu-7hD2EHOPeAynZJ_VG6_lQ"/>
        <activity
            android:name="com.sebab.mapasvegetarianoschile1.MainActivity"
            android:label="@string/app_name" >
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />

                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
        </activity>
    </application>

</manifest>


ANDROID DEVICE IM USING:
Motorola XT531 with Android 2.3.4 (I sent the apk via gmail to my phone and installed it), but it doesnt runs, there is an error (Its in spanish so I dont know which would be the error in english).

On my google account:
Im using the API key that they gave me, but im not sure if the package should be exactly the same, but thats what I wrote. I used the SHA1 that I got from my debug.keystore on it.

What I can do? Which can be the diagnostic? Do you need any information to help me with this issue? Please, ask me whatever you need to help me, it would be perfect. Thanks you.
sebastian.bueno.a
Once Poster
Once Poster
 
Posts: 1
Joined: Fri May 17, 2013 2:52 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 6 guests