threadid=n: still suspended after undo (s=1 d=1)

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

threadid=n: still suspended after undo (s=1 d=1)

Postby peter_canthropus » Mon Dec 13, 2010 3:11 pm

Hey people,

i have 2 classes, my main activity and a "manager" class that takes care of a couple of things and works in another thread.

This is the Activity:

Code: Select all
public void onCreate(Bundle savedInstanceState) {
    super.onCreate(savedInstanceState);
    setContentView(R.layout.main);

    Manager m = new Manager();
    m.startManager();
}

And this the "Manager" class:

Code: Select all
Thread t;

public Manager() {
    t = new Thread(this);
}

public void startManager() {
    t.start();
}

@Override
public void run() {
}


Is really simple, as you can see and if i run the code there's no problem at all, but when i debug in Eclipse, doing "Step over" i get the error from the title:

threadid=: still suspended after undo (s=1 d=1)

This error comes out exactly after t.start();. After that point, if i run the code, it appears to works fine. But when i debug all i get line after line is that same message, so i can't know for sure what's happening with my code.

I jut don't get why this is happening, is like the most simple thread snippet possible.
peter_canthropus
Freshman
Freshman
 
Posts: 4
Joined: Thu Nov 04, 2010 3:14 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 2 guests