SDK on Ubuntu Hardy Heron (8.04)

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

SDK on Ubuntu Hardy Heron (8.04)

Postby HuXu » Mon Oct 06, 2008 9:05 pm

So I have Eclipse and the Linux SDK plug in installed...

I followed all the directions but when I go to create a new project i get an error 'An internal error occurred during: "Android SDK Content Loader". ' And then i try to create a project anyways and it keeps getting hung up on either the project name or package name, i fill it all in and it says its not there.

Whats the problem?!
You gotta start somewhere :/
HuXu
Freshman
Freshman
 
Posts: 4
Joined: Wed Sep 24, 2008 11:25 pm

Top

Postby mrosseel » Mon Oct 13, 2008 1:50 pm

Hi,

Don't know what's causing your problem but I'm using eclipse+android without any problems on kubuntu 8.04, and before that on Gentoo.

So I would look towards permission problems ind the dirs you want to create the projects, maybe reinstalling the plugin or eclipse+plugin combination.

Good luck and let us know when you solve the problem

Mike
mrosseel
Developer
Developer
 
Posts: 25
Joined: Sun Sep 21, 2008 11:19 am

Postby selmi » Thu Oct 16, 2008 10:25 pm

i have exactly the same problem
it worked with sdk m5 rc14
after i upgraded to 1.0 r1 it shows this internal error
i even deleted all eclipse config files, workspace... reinstalled everything... nothing helped so far

this is what eclipse says about it:
An internal error occurred during: "Android SDK Content Loader".
stack trace:
java.lang.NoSuchMethodError: org.eclipse.core.runtime.Status.<init>(ILjava/lang/String;Ljava/lang/String;Ljava/lang/Throwable;)V
at com.android.ide.eclipse.adt.AdtPlugin.log(Unknown Source)
at com.android.ide.eclipse.adt.AdtPlugin$12.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
session data:
eclipse.buildId=M20070212-1330
java.version=1.6.0_07
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86
selmi
Freshman
Freshman
 
Posts: 7
Joined: Wed Mar 05, 2008 4:49 am
Location: Košice, Slovakia

Postby selmi » Fri Oct 17, 2008 10:47 pm

problem is solved
android sdk in version 1.0 doesn't work with eclipse 3.2 anymore. unfortunately this is version available in ubuntu repositories. so solution is to download latest tar.gz package directly from eclipse creators and install it manually
selmi
Freshman
Freshman
 
Posts: 7
Joined: Wed Mar 05, 2008 4:49 am
Location: Košice, Slovakia

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Google Feedfetcher and 4 guests