Physical device won't show up, Emulator works just fine

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Physical device won't show up, Emulator works just fine

Postby eewestcoaster » Thu Jan 06, 2011 2:59 am

I've got a weird one for you guys...

When I plug my phone into my computer it begins charging but won't show up in Eclipse as a valid running Android device. My program works just fine in the emulator, but I can't test it on my Droid.

This seems to have occurred after Gingerbread was released. My phone got the update and if memory serves, this is when it quit working. I was developing primarily on the Emulator at the time, so I can't be sure. My phone shows Android version 2.2.1 though, which is further puzzling me as I assumed it would show v2.3. It's a Motorola Droid (the original one).

I upgraded the SDK through Eclipse and while it still works fine through the emulator, it patently refuses to recognize my Droid when I plug it in. I need to do some final testing on an app that I'm about to publish, but I'm at a standstill until I can use a physical phone.

I haven't yet tried downgrading to v2.2, maybe that's my solution. I suppose it's possible that the old Droid just can't handle Gingerbread and is thus incompatible with the upgrade. Just thinking out loud here, I'm really hoping someone can give me a better answer.

Has anyone else seen this?

Thanks in advance!
eewestcoaster
Freshman
Freshman
 
Posts: 2
Joined: Tue Jan 12, 2010 9:58 pm

Top

Re: Physical device won't show up, Emulator works just fine

Postby eewestcoaster » Fri Jan 07, 2011 7:27 am

Update, in case any of you ran into the same thing.

The issue turned out to be driver related. I had downloaded the new USB driver through the AVD update utility along with the new SDK and everything else. Thing is, I neglected to actually install the new driver.

I removed the existing driver and re-installed it through Windows using the newly downloaded USB driver, and it works like a charm.
eewestcoaster
Freshman
Freshman
 
Posts: 2
Joined: Tue Jan 12, 2010 9:58 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 8 guests