Newbie & DDMS exception

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Newbie & DDMS exception

Postby tweety » Mon Dec 13, 2010 2:04 pm

Hello.

I've installed android sdk r08 under windows xp sp3.
I also installed eclipse helios sr1 with android development tools, android ddms and android hierarchy viewer 8.0.1.

I've created an avd and a simple android project displaying a listview with some data from an array.

It's working fine using run as ... android application.

But ... the first time, everything is ok.
The second time (and the next ones),and the application itself keep working fine, but I've got ddms console errors :

Code: Select all
[2010-12-13 13:47:09 - ddms]null
java.lang.NullPointerException
   at com.android.ddmlib.Client.sendAndConsume(Client.java:571)
   at com.android.ddmlib.HandleHello.sendHELO(HandleHello.java:142)
   at com.android.ddmlib.HandleHello.sendHelloCommands(HandleHello.java:65)
   at com.android.ddmlib.Client.getJdwpPacket(Client.java:670)
   at com.android.ddmlib.MonitorThread.processClientActivity(MonitorThread.java:317)
   at com.android.ddmlib.MonitorThread.run(MonitorThread.java:263)

[2010-12-13 13:47:09 - ddms]null
java.lang.NullPointerException
   at com.android.ddmlib.Client.sendAndConsume(Client.java:571)
   at com.android.ddmlib.HandleHello.sendHELO(HandleHello.java:142)
   at com.android.ddmlib.HandleHello.sendHelloCommands(HandleHello.java:65)
   at com.android.ddmlib.Client.getJdwpPacket(Client.java:670)
   at com.android.ddmlib.MonitorThread.processClientActivity(MonitorThread.java:317)
   at com.android.ddmlib.MonitorThread.run(MonitorThread.java:263)


Code: Select all
12-13 12:47:05.460: DEBUG/AndroidRuntime(478): >>>>>>>>>>>>>> AndroidRuntime START <<<<<<<<<<<<<<
12-13 12:47:05.470: DEBUG/AndroidRuntime(478): CheckJNI is ON
12-13 12:47:06.089: DEBUG/AndroidRuntime(478): --- registering native functions ---
12-13 12:47:08.240: DEBUG/AndroidRuntime(478): Shutting down VM
12-13 12:47:08.251: DEBUG/dalvikvm(478): DestroyJavaVM waiting for non-daemon threads to exit
12-13 12:47:08.260: DEBUG/dalvikvm(478): DestroyJavaVM shutting VM down
12-13 12:47:08.270: DEBUG/dalvikvm(478): HeapWorker thread shutting down
12-13 12:47:08.280: ERROR/AndroidRuntime(478): ERROR: thread attach failed
12-13 12:47:08.290: DEBUG/dalvikvm(478): HeapWorker thread has shut down
12-13 12:47:08.290: DEBUG/jdwp(478): JDWP shutting down net...
12-13 12:47:08.290: INFO/dalvikvm(478): Debugger has detached; object registry had 1 entries
12-13 12:47:08.319: DEBUG/dalvikvm(478): VM cleaning up
12-13 12:47:08.399: DEBUG/dalvikvm(478): LinearAlloc 0x0 used 628980 of 5242880 (11%)
12-13 12:47:09.799: DEBUG/AndroidRuntime(488): >>>>>>>>>>>>>> AndroidRuntime START <<<<<<<<<<<<<<
12-13 12:47:09.809: DEBUG/AndroidRuntime(488): CheckJNI is ON
12-13 12:47:10.359: DEBUG/AndroidRuntime(488): --- registering native functions ---
12-13 12:47:12.300: INFO/ActivityManager(81): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10000000 cmp=com.android.test/.main }
12-13 12:47:12.460: DEBUG/AndroidRuntime(488): Shutting down VM
12-13 12:47:12.460: DEBUG/dalvikvm(488): DestroyJavaVM waiting for non-daemon threads to exit
12-13 12:47:12.490: DEBUG/dalvikvm(488): DestroyJavaVM shutting VM down
12-13 12:47:12.499: DEBUG/dalvikvm(488): HeapWorker thread shutting down
12-13 12:47:12.519: DEBUG/dalvikvm(488): HeapWorker thread has shut down
12-13 12:47:12.519: DEBUG/jdwp(488): JDWP shutting down net...
12-13 12:47:12.529: INFO/dalvikvm(488): Debugger has detached; object registry had 1 entries
12-13 12:47:12.539: DEBUG/dalvikvm(488): VM cleaning up
12-13 12:47:12.679: ERROR/AndroidRuntime(488): ERROR: thread attach failed
12-13 12:47:13.000: DEBUG/dalvikvm(488): LinearAlloc 0x0 used 638948 of 5242880 (12%)
12-13 12:47:13.479: INFO/ActivityManager(81): Displayed activity com.android.test/.main: 1063 ms (total 1063 ms)
12-13 12:47:18.759: DEBUG/dalvikvm(177): GC freed 576 objects / 30984 bytes in 221ms
12-13 12:48:35.263: DEBUG/dalvikvm(81): threadid=15: bogus mon 1+0>0; adjusting


What's happening ? I'm sure it's only a problem with the emulator and not the application but it's quite annoying.
What can I do ?

Thanks.
tweety
Freshman
Freshman
 
Posts: 4
Joined: Mon Dec 13, 2010 1:51 pm

Top

Re: Newbie & DDMS exception

Postby tweety » Wed Dec 15, 2010 8:23 am

Nobody ?
tweety
Freshman
Freshman
 
Posts: 4
Joined: Mon Dec 13, 2010 1:51 pm

Re: Newbie & DDMS exception

Postby vio42 » Sat Apr 02, 2011 4:27 am

The same problem
vio42
Once Poster
Once Poster
 
Posts: 1
Joined: Sat Apr 02, 2011 4:23 am

Re: Newbie & DDMS exception

Postby Yuki.Asahina » Mon Jun 20, 2011 7:02 am

Close xml files you opend of your application.
Yuki.Asahina
Once Poster
Once Poster
 
Posts: 1
Joined: Mon Jun 20, 2011 6:50 am

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests