[Solved] My audio is coming out choppy

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

[Solved] My audio is coming out choppy

Postby Killswitch » Mon Dec 10, 2007 9:53 pm

been workin on the sdk since it popped out started toying around with the mp3 playing
but the sound is chopped as if the cpu is getting chocked or sumthing
quite odd given my system is powerful

your insight would be great

i got 2.0 core2duo
2.5 gig pc5300
vista ultimate
Killswitch
Freshman
Freshman
 
Posts: 5
Joined: Fri Nov 23, 2007 11:27 am

Top

Postby plusminus » Mon Dec 10, 2007 10:17 pm

Hello Killswitch,

playing music inside of an emulator is like playing a 3d-game in a Virtual Machine. Its kinda 'realtime' job. Music will definitely not choke on an actual device ;) .
Haven't heard of someone where the music was not lagging (chopped of).

Btw, I was cheating in my MusicPlayer-Screencast (Added the smooth played music afterwards, because Wink(Screencast-App) did not record the audio-output properly :oops: )

Regards,
plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

Postby plusminus » Sat Jan 05, 2008 12:42 pm

Hey guys,

found this topic and after recent SDK Update (v m3-rc37a) the choppy sound seems to be gone on all platforms.

Regards,
plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Google Feedfetcher and 3 guests