My Application compiles in eclipse but is not in my emul

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

My Application compiles in eclipse but is not in my emul

Postby neilmpatel@gmail.com » Sun Jun 06, 2010 9:54 pm

So my application...the celsius to fahrenheit sample program on this web page
http://www.vogella.de/articles/Android/article.html
compiles just fine.
here is the code from the eclipse console window:
[2010-06-06 15:32:58 - de.vogella.android.tempconverter] Android Launch!
[2010-06-06 15:32:58 - de.vogella.android.tempconverter] adb is running normally.
[2010-06-06 15:32:58 - de.vogella.android.tempconverter] No Launcher activity found!
[2010-06-06 15:32:58 - de.vogella.android.tempconverter] The launch will only sync the application package on the device!
[2010-06-06 15:32:58 - de.vogella.android.tempconverter] Performing sync
[2010-06-06 15:32:58 - de.vogella.android.tempconverter] Automatic Target Mode: Preferred AVD 'neilsavd2' is available on emulator 'emulator-5554'
[2010-06-06 15:33:02 - de.vogella.android.tempconverter] Application already deployed. No need to reinstall.
[2010-06-06 15:33:02 - de.vogella.android.tempconverter] \de.vogella.android.tempconverter\bin\de.vogella.android.tempconverter.apk installed on device
[2010-06-06 15:33:02 - de.vogella.android.tempconverter] Done!



however, when I go to the virtual device which is an android 2.2 target and 2.2 platform, I don't see my app...

I do see the package in the package summary but i just don't know how to run it without having an icon there in the apps area.
The package summary in the emulator(using dev tools app->package informations) says that my package has (no application class , no label, no code)
how can that be?
I'm a REALLY REALLY novice user of both eclipse and Java programming...can anyone help?
neilmpatel@gmail.com
Once Poster
Once Poster
 
Posts: 1
Joined: Sun Jun 06, 2010 9:37 pm

Top

Re: My Application compiles in eclipse but is not in my emul

Postby JKumar » Wed Jun 16, 2010 8:26 am

HI,

Your application is not having a launcher activity found and so it will run in background only as a service.

You can find your app.
Goto Settings->Accounts & Sync -> <your app>

Applications having no launcher will not come in the menu items.

Let me know if it is still missing
Hope the suggestion helps you
Keep posting .It makes us better to understand Android
User avatar
JKumar
Experienced Developer
Experienced Developer
 
Posts: 52
Joined: Thu May 13, 2010 8:17 am
Location: INDIA

Re: My Application compiles in eclipse but is not in my emul

Postby muji316 » Wed Jun 22, 2011 12:36 pm

Hi,

For the android application to launch via eclipse, AndroidManifest.xml file needs to be defined with minimum one activity. The intent filter should determine the main action and launcher category and acts like a startup.

Make sure the format of intent filter is properly followed as shown in an example below:

<activity android:name=".ActivitiesActivity"
android:label="@string/app_name">

<intent-filter>
<action android:name="android.intent.action.MAIN" />
<category android:name="android.intent.category.LAUNCHER" />
</intent-filter>

</activity>

Regards,
Syed Mujtaba Ahmed Razvi
muji316
Once Poster
Once Poster
 
Posts: 1
Joined: Wed Jun 22, 2011 12:26 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 9 guests