Manifest Permissions "quick select" does not exist

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Manifest Permissions "quick select" does not exist

Postby PatrickGlose » Tue Sep 21, 2010 1:01 am

Hi. I tried posting in "views, layouts, and resources", but have not had a response.

Basically, the problem is this;
When I open a manifest.xml to add permissions, and click on Add, and then on "uses", and hit ok, there used to be a drop down list containing some of the most commonly used permissions, and it was easy to add permissions to my manifest. I don't know what happened to that, but now when I Add "uses" permission, instead of the dropdown list, I am getting a list of "strings" within my strings.xml.

I surmize that the wrong editor is being loaded for the manifest, but I have tried 5 times now to reinstall, amongst other things. I have treid eclipse (all Galileo) the EE version, the Developers version, and the Classic version. I have tried it with deleting the Android SDK, but it is not right anymore. I am unable to find any information on this issue, and really need some help. My last resort is to backup my PC and clean it, and we all know how time consuming that can be, so please, please, someone kick up an idea for me.

I am trying to run 32 bit eclipse with the ADK/ADT. My machine is 64bit, but from my understanding, the Android stuff does not run on 64, and so eclipse 32 is required. I believe I am running the 32 bit version of JDK 6 as well.

[EDIT] almost forgot... I have the path set for android to the tools directory, and recently, tried adding the java/bin directory as well. No difference.

Thanks in advance,
Patrick
PatrickGlose
Freshman
Freshman
 
Posts: 5
Joined: Tue Aug 31, 2010 3:00 pm

Top

Re: Manifest Permissions "quick select" does not exist

Postby blundell » Wed Sep 29, 2010 11:42 am

Sorry I've always seen the strings.xml, never used it and just add the permissions manually.
User avatar
blundell
Master Developer
Master Developer
 
Posts: 1610
Joined: Tue Nov 18, 2008 12:58 pm
Location: UK

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 5 guests