Java Version: 1.5?

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Java Version: 1.5?

Postby droozen » Thu Feb 26, 2009 11:40 pm

I might have missed this in the documentation, but does android run on Java 1.5? I first noticed that this must be it when, for example, I have a Calendar object and cal.getDisplayName() function wasn't showing up for me in Eclipse code completion.

Or do I have my Eclipse set up poorly?
droozen
Developer
Developer
 
Posts: 45
Joined: Wed Feb 25, 2009 10:10 pm

Top

Postby MrSnowflake » Thu Feb 26, 2009 11:51 pm

Yes, Android is compatible with 1.5 and earlier, not 1.6! Keep this in mind to if you have desktop libs which you want to use, they can't be 1.6 either!
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Postby droozen » Thu Feb 26, 2009 11:54 pm

Darn. I was afraid of that. I've been using Java 1.6 a lot more lately at work and have gotten quite used to it. I'll have to make my own getDisplayName function, then.
droozen
Developer
Developer
 
Posts: 45
Joined: Wed Feb 25, 2009 10:10 pm

Postby alpesh_harsoda » Wed Apr 29, 2009 1:22 pm

HI mrsnowflake,
andorid is also compitible with java 1.6. :)
Regards,
Alpesh Patel,
Logistic Infotech
http://www.logisticinfotech.com
User avatar
alpesh_harsoda
Senior Developer
Senior Developer
 
Posts: 106
Joined: Sat Sep 20, 2008 12:35 pm
Location: Rajkot,Gujarat(India)

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 7 guests