HTC Magic Problems...

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

HTC Magic Problems...

Postby nradford » Sun May 10, 2009 5:47 pm

Okay, today I've tried setting up my brand new HTC Magic in debug mode, following android.com dev docs.. However, I'm having a problem activating the usb_drivers that come with the SDK.

First, just plugging in my HTC Magic causes windows automatic driver search to search for drivers. The docs assume they won't be found so that the "Add New Hardware" dialog is shown. However, something is found but these drivers appear to be incorrect. At least, incorrect for development (I can still access my SD card). Debug mode is activated on the phone.

I've tried updating the driver windows auto-installs to the one in the SDK but I get an error saying there are no better drivers in the SDK folder for my hardware.

I've tried uninstalling the drivers. However, I can't add the drivers without a reboot, however, after the reboot, plugging my phone in causes the auto install of the wrong drivers again.

Any ideas? Is it a case that the HTC magic isn't reporting stuff right when in Debug mode? (as far as I can gather from looking about, Android effectively opens up different hardware options on the USB when in debug mode) or do I have to wait for the SDK drivers to be updated in order for it to work with the Magic?
nradford
Freshman
Freshman
 
Posts: 2
Joined: Sun May 10, 2009 5:37 pm
Location: UK

Top

solution ;)

Postby zemi » Sat May 23, 2009 5:20 pm

hey i had the same problems and after a long afternoon of searching i found a nice link in google...

follow this guide:
http://www.mail-archive.com/android-beg ... 09692.html

hope this is helpfull ;) greets
I'm sorry for my bad english, but i guess you got the point^^
zemi
Freshman
Freshman
 
Posts: 2
Joined: Sat May 23, 2009 5:12 pm

Postby benbot » Sat Jun 20, 2009 2:21 pm

I had the very same problems and solved it this way:

Search for and download USBDeview.

Make sure your Magic is disconnected and set the USB Debugging to ON.

Right click on USBDeview.exe and select Run as administrator on you XP/
Vista PC.
Select all usb devices relating to HTC and uninstall them ( i found 2)
Reconnect your magic and you should be prompted for the drivers.
Browse to the SDK USB drivers folder and select the .inf file and
click OK. This should re-install the drivers as new for an ADB
Interface.
benbot
Once Poster
Once Poster
 
Posts: 1
Joined: Sat Jun 20, 2009 2:20 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 8 guests