From 1.5 to 2.2

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

From 1.5 to 2.2

Postby ericone » Sat Dec 25, 2010 8:10 pm

Hey guys, the last days i noticed that while using code from official site of android and using a tutorial about creating a simple "listview" my app always crashed(force close). What i realized was that this was happening because i was using 2.2 version api., when i went to older version it worked perfectly; i used 1.5

My question is; does not newer versions of android support older versions code????

P.s
this is my first post ever in a forum, after 15 years of using the internet :)
ericone
Freshman
Freshman
 
Posts: 4
Joined: Sat Dec 25, 2010 7:59 pm

Top

Re: From 1.5 to 2.2

Postby Jems » Sun Dec 26, 2010 8:23 am

They try to keep supporting deprecated features, but there is no guarantee that everything will still work as intended.
Jems
Experienced Developer
Experienced Developer
 
Posts: 57
Joined: Thu Dec 09, 2010 7:42 pm

Re: From 1.5 to 2.2

Postby Schermvlieger » Sun Dec 26, 2010 10:32 am

Hi ericone,

First of all; what does Logcat say? Without that, there's really no telling what's going on, see?
Schermvlieger
Senior Developer
Senior Developer
 
Posts: 159
Joined: Fri Feb 26, 2010 1:37 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 6 guests