Failure [INSTALL_FALLED_OLDER_SDK]

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Failure [INSTALL_FALLED_OLDER_SDK]

Postby Timaphei » Fri Jan 22, 2010 6:22 am

Hello everybody!
My question might seem very silly, but is there any chance to install an application compiled under
Android SDK v2.1 on Android T-Mobile G1 with SDK v1.6?
I constantly get Failure [INSTALL_FALLED_OLDER_SDK] error message.
Thanks in advance.
Timaphei
Freshman
Freshman
 
Posts: 8
Joined: Sat Jul 18, 2009 2:51 pm

Top

Postby cefobid2008 » Wed Jan 27, 2010 7:56 am

I have the same question, even when I tried to install an application compiled under Android SDK v2.0 on SDK v2.1?
cefobid2008
Freshman
Freshman
 
Posts: 4
Joined: Wed Jan 06, 2010 11:18 am

Postby Timaphei » Fri Jan 29, 2010 6:33 am

SOLVED.
What you need to do is to add the following line into your AndroidManifest.xml file:

<uses-sdk android:minSdkVersion="4" />

Works like a charm for me (compiled under SDK 2.1, installed and run on Android T-Mobile G1, sdk 1.6)
Haven't tried that on Motorola Droid with Android 2.0, though. But I guess it should work too.
Timaphei
Freshman
Freshman
 
Posts: 8
Joined: Sat Jul 18, 2009 2:51 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests