Error executing aapt...?

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Error executing aapt...?

Postby Skeniver » Thu Jan 06, 2011 11:13 am

Hi there

I am using Eclipse on a mac and everything has been working championly until yesterday when this error cropped up. aapt is definitely present. I also have reinstalled the SDK in another directory and pointed Eclipse there, but still no go.

Does anybody have any ideas what might be the issue?

Thanks,
Neil
Follow me on twitter -> http://twitter.com/Skeniver
Apps & blog -> http://www.formidableapps.co.uk
User avatar
Skeniver
Senior Developer
Senior Developer
 
Posts: 106
Joined: Tue Feb 03, 2009 3:51 pm
Location: Canterbury, UK

Top

Re: Error executing aapt...?

Postby raffaele181188 » Sat Jan 08, 2011 1:40 pm

It's a shame :evil:

I wasted more than 4 hours and didn't find a solution. I will never update anything related to Eclipse/Android

BTW, I tried to "delete the marker", ie went in Problems tab (can you see it? it's next to "console", "logcat", ..) expanded the problem, right click and choosed "Delete".

Then Eclipse stopped complaining about "aapt not found" (obviously, it's in place) but looooooooots of problem arouse: I cannot use the Launch button, nor the Run configuration menu, the eclipse log is full of errors, plus bonus refreshing external folder bug popping out again, and NPE throwed all over. Oh and -of course- if I manage to run a project, can see the logcat full of strange things like file not found, system executables not found, etc

Feeling so frustrated :cry: Eclipse boasts to be the greatest developement platform in its market, but it's so bugged...
raffaele181188
Freshman
Freshman
 
Posts: 4
Joined: Sat Jan 08, 2011 12:50 pm

Re: Error executing aapt...?

Postby Skeniver » Sat Jan 08, 2011 1:52 pm

I eventually just removed Eclipse and reinstalled fresh. Now all works fine.

It does have its flaws, but what doesn't... Still prefer it to notepad :)
Follow me on twitter -> http://twitter.com/Skeniver
Apps & blog -> http://www.formidableapps.co.uk
User avatar
Skeniver
Senior Developer
Senior Developer
 
Posts: 106
Joined: Tue Feb 03, 2009 3:51 pm
Location: Canterbury, UK

Re: Error executing aapt...?

Postby raffaele181188 » Sat Jan 08, 2011 5:06 pm

I reinstalled Eclipse and reimported my project but still have problems. Seems last ADT upgrade (8.0.1) broke something
raffaele181188
Freshman
Freshman
 
Posts: 4
Joined: Sat Jan 08, 2011 12:50 pm

Re: Error executing aapt...?

Postby uncre8d1 » Wed Jan 12, 2011 9:38 pm

I'm having the same issue, and i coincidentally just updated everything in Eclipse. So I need to roll back to an older version?
Normal?!? Man, I'd give my left arms to be normal.
User avatar
uncre8d1
Junior Developer
Junior Developer
 
Posts: 18
Joined: Tue Mar 16, 2010 3:41 am
Location: Silver Spring, MD

Re: Error executing aapt...?

Postby Skeniver » Thu Jan 13, 2011 8:48 am

You can try rolling back. I completely deleted and reinstalled then just added my existing SDK folder (didn't download that again)

Let me know which works for you!
Follow me on twitter -> http://twitter.com/Skeniver
Apps & blog -> http://www.formidableapps.co.uk
User avatar
Skeniver
Senior Developer
Senior Developer
 
Posts: 106
Joined: Tue Feb 03, 2009 3:51 pm
Location: Canterbury, UK

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 6 guests