Eclipse Not Responding

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Eclipse Not Responding

Postby Phobos » Sun Sep 05, 2010 11:25 am

Hello everyone. I am developing in Eclipse Galileo and was doing just fine, except android likes to shred some of my objects, until I updated my Java to 1.6_21. Now Eclipse will do everything I expect and as an added bonus it will randomly freeze and show Not Responding. :shock: I save like crazy now because the first time this happened I lost about an hour worth of code writing.

Is anyone else experiencing the same issue? I searched for this issue on the board and didnt see anything. I am a newbie when it comes to Java, but am learning. I am developing on an amd turion 64x2 windows 7 with 4GB ram. Any help would be greatly appreciated.
Phobos
Freshman
Freshman
 
Posts: 3
Joined: Sat Aug 28, 2010 1:17 am

Top

Re: Eclipse Not Responding

Postby nickt » Sun Sep 05, 2010 1:10 pm

Hi,

There is a known problem with Eclipse and Java 1.6_21. It even warns about it on the Eclipse download page.

http://www.eclipse.org/downloads/

with the message
"Attention Windows users running Java 1.6.0 update 21 with Eclipse. Please follow the instructions here to resolve crashing and freezing issues."

Click the hyperlink under the word 'here' and it tells you what to do. Apparently build b06 was no good, build b07 should fix it.
nickt
Freshman
Freshman
 
Posts: 6
Joined: Mon Feb 22, 2010 1:05 pm

Re: Eclipse Not Responding

Postby Phobos » Sun Sep 05, 2010 10:57 pm

Thank You Very Much. You have saved my sanity.
Phobos
Freshman
Freshman
 
Posts: 3
Joined: Sat Aug 28, 2010 1:17 am

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 9 guests