[FIXED] Eclipse and ADT not working

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

[FIXED] Eclipse and ADT not working

Postby onlineadr » Mon Sep 19, 2011 2:34 pm

[FIXED]

Somehow re-downloading the SDK solved this

Eclipse has just recently stopped working for me...

when i start eclipse i get this error:

[2011-09-19 21:25:09 - adb]Failed to parse the output of 'adb version'

even though i know its pointing to the correct location for adb which is C:\Android\android-sdk-windows\platform-tools\adb.exe

but when i go to try to run an application i seem to get this error:

[2011-09-19 21:27:53 - DeskDroid] ------------------------------
[2011-09-19 21:27:53 - DeskDroid] Android Launch!
[2011-09-19 21:27:53 - DeskDroid] The connection to adb is down, and a severe error has occured.
[2011-09-19 21:27:53 - DeskDroid] You must restart adb and Eclipse.
[2011-09-19 21:27:53 - DeskDroid] Please ensure that adb is correctly located at 'C:\Android\android-sdk-windows\platform-tools\adb.exe' and can be executed.

now if i go to ADB via cmd it runs fine

Here is what i have done
SDK has been on this machine for +6 months
Installed all google packages in the SDK
Removed Helios (was not working as well)
i've updated Eclipse to Indigo
Installed ADT

i just don't understand why it is not working for me

N.B. simply doing adb kill-server and adb start-server does nothing
onlineadr
Experienced Developer
Experienced Developer
 
Posts: 59
Joined: Thu Apr 28, 2011 12:45 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 3 guests