DefaultHTTPClient problem ater setting speed and latency

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

DefaultHTTPClient problem ater setting speed and latency

Postby Franze » Tue May 03, 2011 10:34 am

Hello,

i hope you can help me, i'm desperated.

First of all i build a simple HTTP Echo Server with sun.net.httpserver.HttpServerImpl.create(new InetSocketAddress(8080), 0);

Then in my Android App i use a DefaultHttpServer and send the HttpRequest with the execute() Method. Everything works fine, till i set the speed to anything beside "Full". Then i got the following exception:

Code: Select all
05-03 09:30:48.625: WARN/System.err(500): java.net.SocketException: Connection reset by peer
05-03 09:30:48.655: WARN/System.err(500):     at org.apache.harmony.luni.platform.OSNetworkSystem.read(Native Method)
05-03 09:30:48.655: WARN/System.err(500):     at dalvik.system.BlockGuard$WrappedNetworkSystem.read(BlockGuard.java:273)
05-03 09:30:48.664: WARN/System.err(500):     at org.apache.harmony.luni.net.PlainSocketImpl.read(PlainSocketImpl.java:458)
05-03 09:30:48.664: WARN/System.err(500):     at org.apache.harmony.luni.net.SocketInputStream.read(SocketInputStream.java:85)
05-03 09:30:48.664: WARN/System.err(500):     at org.apache.http.impl.io.AbstractSessionInputBuffer.fillBuffer(AbstractSessionInputBuffer.java:103)
05-03 09:30:48.664: WARN/System.err(500):     at org.apache.http.impl.io.AbstractSessionInputBuffer.readLine(AbstractSessionInputBuffer.java:191)
05-03 09:30:48.675: WARN/System.err(500):     at org.apache.http.impl.conn.DefaultResponseParser.parseHead(DefaultResponseParser.java:82)
05-03 09:30:48.675: WARN/System.err(500):     at org.apache.http.impl.io.AbstractMessageParser.parse(AbstractMessageParser.java:174)
05-03 09:30:48.675: WARN/System.err(500):     at org.apache.http.impl.AbstractHttpClientConnection.receiveResponseHeader(AbstractHttpClientConnection.java:179)
05-03 09:30:48.685: WARN/System.err(500):     at org.apache.http.impl.conn.DefaultClientConnection.receiveResponseHeader(DefaultClientConnection.java:235)
05-03 09:30:48.694: WARN/System.err(500):     at org.apache.http.impl.conn.AbstractClientConnAdapter.receiveResponseHeader(AbstractClientConnAdapter.java:259)
05-03 09:30:48.705: WARN/System.err(500):     at org.apache.http.protocol.HttpRequestExecutor.doReceiveResponse(HttpRequestExecutor.java:279)
05-03 09:30:48.715: WARN/System.err(500):     at org.apache.http.protocol.HttpRequestExecutor.execute(HttpRequestExecutor.java:121)
05-03 09:30:48.725: WARN/System.err(500):     at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:421)
05-03 09:30:48.725: WARN/System.err(500):     at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:555)
05-03 09:30:48.735: WARN/System.err(500):     at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:487)
05-03 09:30:48.735: WARN/System.err(500):     at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:465)


Do you have any ideas?
Franze
Freshman
Freshman
 
Posts: 2
Joined: Tue May 03, 2011 10:11 am

Top

Re: DefaultHTTPClient problem ater setting speed and latency

Postby Franze » Tue May 03, 2011 10:38 am

i also tried it with the AndroidHttpClient.

Same Problem :/

Edit: With the setting "HSDPA" in the emulator i works fine.

But for my bachelor thesis i have to set the speed to GPRS :/
Franze
Freshman
Freshman
 
Posts: 2
Joined: Tue May 03, 2011 10:11 am

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Google Feedfetcher and 6 guests