conexion problem

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

conexion problem

Postby medi88 » Tue Mar 29, 2011 11:23 am

conexion with the emulator don't existe
and when i try to download the other sdk in avd manager
i get Failed to fetch URL https://dl-ssl.google.com/android/repos ... sitory.xml, reason: Connection refused: connect

i have a firewall but i can't disable it
soo can i know the port's numbers that eclipse and android emulator us to add them in exepctions of the firewall

or if u have another solutions
medi88
Freshman
Freshman
 
Posts: 9
Joined: Tue Mar 29, 2011 11:19 am

Top

Re: conexion problem

Postby raj_J2ME » Tue Mar 29, 2011 12:25 pm

Are you following the procedure that is mentioned here below?
http://developer.android.com/sdk/eclipse-adt.html
please check and revert.
Thanks with Regards,
Raj - The Kernel
raj_J2ME
Master Developer
Master Developer
 
Posts: 311
Joined: Tue Feb 15, 2011 7:40 am
Location: The Capital of India,

Re: conexion problem

Postby medi88 » Tue Mar 29, 2011 12:38 pm

Yeah
also ; last week everything was okéé (google maps ; emulator ; sdk downloads)
this weekend nothing's working
medi88
Freshman
Freshman
 
Posts: 9
Joined: Tue Mar 29, 2011 11:19 am

Re: conexion problem

Postby raj_J2ME » Tue Mar 29, 2011 12:48 pm

Means you are not able to create the new android project even.
Did you try :
Help > check for updates
and was this completed successfully?
you can try to do the settings again.
Thanks with Regards,
Raj - The Kernel
raj_J2ME
Master Developer
Master Developer
 
Posts: 311
Joined: Tue Feb 15, 2011 7:40 am
Location: The Capital of India,

Re: conexion problem

Postby medi88 » Tue Mar 29, 2011 12:53 pm

No i can create a new project
but i can use internet conexion in my emulatooor
it's blocked
medi88
Freshman
Freshman
 
Posts: 9
Joined: Tue Mar 29, 2011 11:19 am

Re: conexion problem

Postby raj_J2ME » Tue Mar 29, 2011 1:00 pm

I guess that this is due to the anti virus/firewall, for the sake of testing why don't you off the firewall for a couple of minutes. Try to edit some setting for the emulator in antivirus settings.
Thanks with Regards,
Raj - The Kernel
raj_J2ME
Master Developer
Master Developer
 
Posts: 311
Joined: Tue Feb 15, 2011 7:40 am
Location: The Capital of India,

Top

Re: conexion problem

Postby medi88 » Tue Mar 29, 2011 1:02 pm

I"m working with an entreprise sooo i can't off the firewaaall ; but i can add some exeptions port
soo if u know the port that android emulator is using
medi88
Freshman
Freshman
 
Posts: 9
Joined: Tue Mar 29, 2011 11:19 am

Re: conexion problem

Postby medi88 » Tue Mar 29, 2011 4:10 pm

I think it's the proxyy
i configure it in my emulator
browser is working
but maps or when i try to connecte with a distant server
nothing's working
medi88
Freshman
Freshman
 
Posts: 9
Joined: Tue Mar 29, 2011 11:19 am

Re: conexion problem

Postby medi88 » Tue Mar 29, 2011 4:26 pm

I found the solution thx
u need to config ur emulator with the proxy and port with
emulator -avd <nom_avd> -http-proxy <proxy>
medi88
Freshman
Freshman
 
Posts: 9
Joined: Tue Mar 29, 2011 11:19 am

Re: conexion problem

Postby raj_J2ME » Tue Mar 29, 2011 7:03 pm

medi88 wrote:I found the solution thx
u need to config ur emulator with the proxy and port with
emulator -avd <nom_avd> -http-proxy <proxy>

Hey thats great.. :)

Thanks for sharing the solution too, which can be referred by someone else later.
Thanks with Regards,
Raj - The Kernel
raj_J2ME
Master Developer
Master Developer
 
Posts: 311
Joined: Tue Feb 15, 2011 7:40 am
Location: The Capital of India,

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 7 guests