Can't run a project

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Can't run a project

Postby OlegSokolov » Wed Jul 13, 2011 3:46 pm

[2011-07-13 18:01:19 - HelloAndroid] ------------------------------
[2011-07-13 18:01:19 - HelloAndroid] Android Launch!
[2011-07-13 18:01:19 - HelloAndroid] adb is running normally.
[2011-07-13 18:01:19 - HelloAndroid] Performing com.example.helloandroid.HelloAndroid activity launch
[2011-07-13 18:01:19 - HelloAndroid] Automatic Target Mode: launching new emulator with compatible AVD '31andr'
[2011-07-13 18:01:19 - HelloAndroid] Launching a new emulator with Virtual Device '31andr'
[2011-07-13 18:01:19 - Emulator] PANIC: Could not open AVD config file: C:\Users\Олег\.android\avd\31andr.avd/config.ini

What's the problem? File config.ini exists in this directory. But why is there reversed slash in the path??
OlegSokolov
Once Poster
Once Poster
 
Posts: 1
Joined: Wed Jul 13, 2011 3:35 pm

Top

Re: Can't run a project

Postby matan » Mon Jul 25, 2011 9:53 am

Hello Everyone!
I have this problem.
Can you help me,please?
Thanks.
matan
Freshman
Freshman
 
Posts: 2
Joined: Mon Jul 25, 2011 9:48 am

Re: Can't run a project

Postby matan » Tue Jul 26, 2011 3:21 pm

I found the solution!
The SDK saves your AVD card in C:\Users\your_user_name_in_windows\.android\avd\
If your username in windows is not written with only english letters (for example, if your username uses non-english letters), it causes this problem.
The solution is to change your username in windows, or create a user whose name is written with only english letters.
matan
Freshman
Freshman
 
Posts: 2
Joined: Mon Jul 25, 2011 9:48 am

Re: Can't run a project

Postby hello_all2 » Mon Sep 19, 2011 10:30 am

hi all!
I have the same problem and you solution don't work on my computer. how can I change the name in a different way? or do you know how ta change the position of the avd file? can you help me?
thanks.
hello_all2
Once Poster
Once Poster
 
Posts: 1
Joined: Mon Sep 19, 2011 10:19 am

Re: Can't run a project

Postby csn » Sat Nov 19, 2011 2:55 am

Alright, so im having the same problem, (getting the message PANIC: Could not open AVD config file: C:\Användare\Fotbollen\.android\avd\Phone.avd/config.ini). My problem is not a non-english character in the user name, its a special character in the folder for Users itself! Namely my computer is running a Swedish version of windows XP, and so presumably its getting hung up on the Ä in "Användare." Is there some way to move the .android folder somewhere else, then update the path eclipse is using to look for it? I am not sure how else to do it, if the program cant find anything stored in the User folders. Any help would be appreciated, thanks!
csn
Once Poster
Once Poster
 
Posts: 1
Joined: Sat Nov 19, 2011 2:26 am

Re: Can't run a project

Postby dmtulsa » Mon Dec 12, 2011 8:59 pm

Same problem here. Each AVD is around 16gb. I have a SSD drive and having a few AVD's really eats up drive space
dmtulsa
Freshman
Freshman
 
Posts: 3
Joined: Mon Dec 12, 2011 6:23 pm

Top

Re: Can't run a project

Postby m.grinvalsky » Wed Dec 21, 2011 1:46 pm

Hi, I find sultion/hack that seems to work (being novice Android developer).

My solution is:

1) create folder "C:\Users\Олег\.android" (in general, just name it after the username seen by ADT as location for config files)

2) Create directory junction "makelink /J C:\Users\Олег\.android\avd REAL_PATH_TO_avd_DIRECTORY" (replace the C:\Users\Олег\.android\avd REAL_PATH_TO_avd_DIRECTORY with path to avd directory under your profile - inmy case it was "makelink /J C:\Users\Matúš\.android\avd C:\Users\Matúš\.android\avd"

You are good to go ;-)
m.grinvalsky
Once Poster
Once Poster
 
Posts: 1
Joined: Wed Dec 21, 2011 1:30 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Google [Bot] and 7 guests