Build Target

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Build Target

Postby Lippy86 » Fri Dec 24, 2010 3:31 am

What build target do you guys use when you are making apps? Do you select the latest one out or an earlier one? The apps I've been making/learning with I've been using 2.3 but then when I try to put it on my phone its not compatible because I don't have that version. Do you use an earlier version then? Or do you expect people to have the latest one?
Lippy86
Freshman
Freshman
 
Posts: 5
Joined: Tue Dec 14, 2010 12:51 am

Top

Re: Build Target

Postby Jems » Fri Dec 24, 2010 8:24 am

You should probably try to target the earliest android version that you can- but its not actually worth going back beyond a certain point.
Visit http://developer.android.com/resources/ ... sions.html to see what the ecosystem of versions is like based on devices that accessed the market. They update this fairly reguarly. You should be fine if you set the target to 2.1 or higher now. Don't assume everyone has the latest version (2.3), since some people can't upgrade for various reasons, and it takes time for vendors to push their specific builds out to their users.
Also, don't set a max sdk version unless absolutely necessary.
Jems
Experienced Developer
Experienced Developer
 
Posts: 57
Joined: Thu Dec 09, 2010 7:42 pm

Re: Build Target

Postby Lippy86 » Fri Dec 24, 2010 9:01 am

I did set a min sdk version, thats probably why I can't install them on my phone. Thanks for the advice!
Lippy86
Freshman
Freshman
 
Posts: 5
Joined: Tue Dec 14, 2010 12:51 am

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 8 guests