Application launch Canceled by emulator (m5 SDK)

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Application launch Canceled by emulator (m5 SDK)

Postby Anil » Wed Feb 20, 2008 11:40 pm

I upgraded to the m5 SDK, updated path, manifest, layout etc.
Tried to run application:

[2008-02-20 15:49:17 - juwo android] ------------------------------
[2008-02-20 15:49:17 - juwo android] Android Launch!
[2008-02-20 15:49:18 - juwo android] adb is running normally.
[2008-02-20 15:49:18 - juwo android] Launching: com.jo.blockpad.JoViewer
[2008-02-20 15:49:18 - juwo android] Automatic Target Mode: launch emulator.
[2008-02-20 15:49:18 - juwo android] Launching a new emulator.
[2008-02-20 15:53:44 - juwo android] New emulator found: emulator-tcp-5555
[2008-02-20 15:55:56 - juwo android] emulator-tcp-5555 disconnected! Cancelling 'com.jo.blockpad.JoViewer' launch!


I tried to see what was in Logcat but see this error:

Problems occurred restoring perspective.
Could not find view: com.android.ide.eclipse.ddms.views.LogCatView
Could not find view: com.android.ide.eclipse.ddms.views.DeviceView
Could not find view: com.android.ide.eclipse.ddms.views.ProcessView
Could not find view: com.android.ide.eclipse.ddms.views.EmulatorControlView
Could not find view: com.android.ide.eclipse.ddms.views.ThreadView
Could not find view: com.android.ide.eclipse.ddms.views.HeapView
Could not find view: com.android.ide.eclipse.ddms.views.FileExplorerView

Anyone know what is happening?

thanks,
Anil
Anil
Developer
Developer
 
Posts: 44
Joined: Fri Jan 04, 2008 9:15 pm

Top

Postby plusminus » Wed Feb 20, 2008 11:49 pm

Hello Anil,

these are all the Views in DDMS...
Could not find view: com.android.ide.eclipse.ddms.views.LogCatView
Could not find view: com.android.ide.eclipse.ddms.views.DeviceView
Could not find view: com.android.ide.eclipse.ddms.views.ProcessView
Could not find view: com.android.ide.eclipse.ddms.views.EmulatorControlView
Could not find view: com.android.ide.eclipse.ddms.views.ThreadView
Could not find view: com.android.ide.eclipse.ddms.views.HeapView
Could not find view: com.android.ide.eclipse.ddms.views.FileExplorerView


maybe something went wrong on updating you ADT (did you update or remove and install :?: )

Regards,
plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

Postby Anil » Thu Feb 21, 2008 12:18 am

Thanks for replying plusminus!
I updated ADT with a new download of Eclipse for Java (since it has WST).
not sure what you man by "remove".
On the other hand, I am able to run APIDemos which are preloaded in the emulator.
thanks,
Anil

plusminus wrote:Hello Anil,

these are all the Views in DDMS...
Could not find view: com.android.ide.eclipse.ddms.views.LogCatView
Could not find view: com.android.ide.eclipse.ddms.views.DeviceView
Could not find view: com.android.ide.eclipse.ddms.views.ProcessView
Could not find view: com.android.ide.eclipse.ddms.views.EmulatorControlView
Could not find view: com.android.ide.eclipse.ddms.views.ThreadView
Could not find view: com.android.ide.eclipse.ddms.views.HeapView
Could not find view: com.android.ide.eclipse.ddms.views.FileExplorerView


maybe something went wrong on updating you ADT (did you update or remove and install :?: )

Regards,
plusminus
Anil
Developer
Developer
 
Posts: 44
Joined: Fri Jan 04, 2008 9:15 pm

Postby plusminus » Thu Feb 21, 2008 1:12 am

Hello Anil,

I tried to say, that you could have tried to remove the ADT first and then install it again.
Because actually updating the ADT doesn't work in most cases.

Fine, that it is working now :)

Regards,
plusminus
Image
Image | Android Development Community / Tutorials
User avatar
plusminus
Site Admin
Site Admin
 
Posts: 2688
Joined: Wed Nov 14, 2007 8:37 pm
Location: Schriesheim, Germany

Postby Anil » Thu Feb 21, 2008 1:17 am

plusminus wrote:Hello Anil,

I tried to say, that you could have tried to remove the ADT first and then install it again.
Because actually updating the ADT doesn't work in most cases.

Fine, that it is working now :)

Regards,
plusminus


Actually, it isnt working. I downloaded and installed Eclipse for Java since Eclipse 3.3.1
Classic didn't have WST needed for the Android Editor. Isn't that sufficient?
the plugin is installed in the eclipse folder, and not in the workspace right?
I renamed the old eclipse folder and installed Eclipse into eclipse
Should I delete the Android profile in c:Docs and Settings... also?

Installation History
The list below represents the history of your update activities from
the product installation to date. Each operation carries a date it
commenced, as well as activities performed. Operations are sorted by
date in ascending order.

Feb 20, 2008 12:41:26 PM
Date / Time Target Action Status
Feb 20, 2008 12:43:24 PM file:/C:/eclipse/ site-install success

Feb 20, 2008 1:02:14 PM
Date / Time Target Action Status
Feb 20, 2008 1:02:01 PM com.android.ide.eclipse.adt_0.4.0.200802081635
feature-install success
Feb 20, 2008 1:02:13 PM com.android.ide.eclipse.adt_0.4.0.200802081635
feature-enable success
Feb 20, 2008 1:02:13 PM
com.android.ide.eclipse.editors_0.2.0.200802081635 feature-install
success
Feb 20, 2008 1:02:13 PM
com.android.ide.eclipse.editors_0.2.0.200802081635 feature-enable
success
Anil
Developer
Developer
 
Posts: 44
Joined: Fri Jan 04, 2008 9:15 pm

Postby Anil » Thu Feb 21, 2008 4:15 am

Ok, it is fixed.
I don't know what fixed it but it could be two things:
  • I launched the old install of Eclipse 3.3.1 and uninstalled ADT; then I launched the new Eclipse For Java install and uninstalled and reinstalled ADT.
  • Also I wonder whether this could also have been the cause: A waiting for debugger dialog pops up with a "force close" button and I would automatically close it without any ill effects - this time I simply waited for it to complete.
thanks,
Anil
Anil
Developer
Developer
 
Posts: 44
Joined: Fri Jan 04, 2008 9:15 pm

Top

Postby kiran » Thu Feb 21, 2008 5:02 am

While upgrading to the new ADT. You have to first uninstall ADT, restart Eclipse and then make a fresh ADT install for new ADT to work correctly.
:) smile it is the key that fits the lock of everybody's heart
User avatar
kiran
Experienced Developer
Experienced Developer
 
Posts: 78
Joined: Thu Nov 22, 2007 11:36 am
Location: India

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 2 guests