App runs on Platform 1.5 but not on 1.6

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

App runs on Platform 1.5 but not on 1.6

Postby BlueSky » Fri Feb 04, 2011 5:43 pm

My application runs on Platform 1.5/API Level 3 without errors.
Now I want to change to version 1.6 to support multiple screen sizes
("Starting from Android 1.6, the platform provides support for multiple screen sizes and resolutions,..." ... pport.html)

My IDE is Eclipse. I didn't change program code.
I changed <uses-sdk android:minSdkVersion="3" /> to <uses-sdk android:minSdkVersion="4" />
in the AndroidManifest.xml and I changed Properties (right click at program name->Properties
and made a hook at "Android 1.6/API Level 4" instead at "Android 1.5/API Level 3".
Also I cleaned the project (Project->Clean...).

But if I now start my app I see only about one second the screen of my app and then an
automatically return to the Android start screen.

Have I to do other changes to change from Android 1.5 to 1.6?
Posts: 6
Joined: Thu Feb 03, 2011 10:38 pm


Re: App runs on Platform 1.5 but not on 1.6

Postby blundell » Tue Feb 08, 2011 2:21 pm

Read your LogCat for the actual error.
User avatar
Master Developer
Master Developer
Posts: 1610
Joined: Tue Nov 18, 2008 12:58 pm
Location: UK


Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 7 guests