Android Virtual Device Issue

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

Android Virtual Device Issue

Postby Maxood » Sun Aug 02, 2009 1:44 pm

I am a newbie and like to do development on android. I have just downloaded, unzipped the SDK and installed it. When i type emulator on the command prompt i recieve the following error:

emaulator: ERROR: You did not provide the name of Android Virtual Device with the '-avd <name>' option. Read -help-avd for more information.

Please resolve and let me know what to do about it.

How do we create these AVDs and why do we need them?

Your help and guidelines would be appreciated.
Maxood

"Life is an endless journey to achieve perfection"
Maxood
Developer
Developer
 
Posts: 34
Joined: Sun Aug 02, 2009 1:37 pm
Location: Karachi, Pakistan

Top

Postby nmc » Sun Aug 02, 2009 4:47 pm

nmc
Senior Developer
Senior Developer
 
Posts: 154
Joined: Thu Nov 27, 2008 8:30 pm
Location: Germany

Cannot create AVD

Postby Maxood » Sun Aug 02, 2009 8:08 pm

I have read the tutorial and followed it. When i run the command: android create avd -n maxood -t 1
I get strange message for java usage like:

Usage: java [options] class [args...]
<to execute a class>.....
...................................................
..................................................
..................................................


Please help me out , why is that happening with me. Whats really wrong?
Maxood

"Life is an endless journey to achieve perfection"
Maxood
Developer
Developer
 
Posts: 34
Joined: Sun Aug 02, 2009 1:37 pm
Location: Karachi, Pakistan

Postby nmc » Sun Aug 02, 2009 11:29 pm

You get this error for every command?
So (for example) "android list targets" fail with the same (or a similar) error?

Anyway, looks like something is wrong with your java installation, so i would recommend to reinstall the latest java version as well as the android sdk.
nmc
Senior Developer
Senior Developer
 
Posts: 154
Joined: Thu Nov 27, 2008 8:30 pm
Location: Germany

Postby Maxood » Mon Aug 03, 2009 7:13 am

Yes.I am getting this error for all the commands i am running from the command prompt. Please provide link of the latest version of JDK i need to install. I am going to reinstall the JDK and also the SDK as well.

I have the following on my system:

Operating System: Windows XP Service Pack 2
Processor: AMD Athlon(tm) 64x 2 Dual Core Processor
Memory: 1.87 GHz of RAM



Please let me know if any other pre-requisites i have to fulfill.

Thank you,
Maxood

"Life is an endless journey to achieve perfection"
Maxood
Developer
Developer
 
Posts: 34
Joined: Sun Aug 02, 2009 1:37 pm
Location: Karachi, Pakistan

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: Exabot [Bot] and 9 guests