ActivityGroup + ListView => Search Button doesn't work

Common bugs/problems with the Android SDK the Emulator and the ADT-Plugin.

ActivityGroup + ListView => Search Button doesn't work

Postby haemi » Wed Nov 10, 2010 2:58 pm

Hi all,

in my application, I'm using ActivityGroup to have different activities in the same tab. Everything works as expected, only the (hardware) search buttons leads to an exception, if I click it on the view with a ListView in it: java.lang.IllegalArgumentException: no ident.

If I remove the ListView, the exception isn't thrown.

What am I doing wrong?

Thanks a LOT,

haemi
haemi
Freshman
Freshman
 
Posts: 6
Joined: Wed Nov 10, 2010 2:48 pm

Top

Re: ActivityGroup + ListView => Search Button doesn't work

Postby alpesh » Fri Nov 12, 2010 5:35 am

Hello

you can find your solution from below link

http://ericharlow.blogspot.com/2010/09/ ... ities.html
alpesh
Developer
Developer
 
Posts: 25
Joined: Wed Oct 06, 2010 6:22 am
Location: Ahmedabad - gujarat - india

Re: ActivityGroup + ListView => Search Button doesn't work

Postby haemi » Thu Nov 18, 2010 10:28 pm

alpesh wrote:Hello

you can find your solution from below link

http://ericharlow.blogspot.com/2010/09/ ... ities.html


Unfortunately, I can't. I already asked the author of that post (see comment section at the end); he didn't have a solution for me either :(
haemi
Freshman
Freshman
 
Posts: 6
Joined: Wed Nov 10, 2010 2:48 pm

Re: ActivityGroup + ListView => Search Button doesn't work

Postby andreslr » Tue Feb 01, 2011 9:25 am

Hi Haemi,

Im trying to do the same, how did you handled to show the search result in the same tab?
andreslr
Junior Developer
Junior Developer
 
Posts: 12
Joined: Wed Jul 01, 2009 6:44 pm

Re: ActivityGroup + ListView => Search Button doesn't work

Postby haemi » Tue Feb 01, 2011 9:36 am

unfortunately, I had to do a workaround.

Instead of using ActivityGroup and different activities, I'm using a FlipViewer now...
haemi
Freshman
Freshman
 
Posts: 6
Joined: Wed Nov 10, 2010 2:48 pm

Re: ActivityGroup + ListView => Search Button doesn't work

Postby andreslr » Tue Feb 01, 2011 5:02 pm

Do you know any good tutorial for that?
andreslr
Junior Developer
Junior Developer
 
Posts: 12
Joined: Wed Jul 01, 2009 6:44 pm

Top

Return to SDK/ADT/Emulator Problems

Who is online

Users browsing this forum: No registered users and 5 guests