Invisible files on Archos 5 device

Put your problem here if it does not fit any of the other categories.

Invisible files on Archos 5 device

Postby fpdiver » Thu May 27, 2010 2:46 pm

I am fairly new to Android and this is my first post so I apologise in advance if I am breaking protocol or posting to the wrong board. Please feel free to move this post to somewhere more appropriate if required.

I am developing for the 160 Gb Archos 5 Internet tablet. Not ideal as a development platform I know, but customer requirements mean we have no choice. It is running Android 1.6. I have updated the device firmware to the most recent available. Updating the version of Android is not an option at this point.

Part of my app's requirement is to write information out to .txt files on the external storage directory so that these can be copied over the USB connection to a Windows XP PC using the Mobile media device (MTP) mode.

I have followed all instructions I have come across carefully, eg I check that the storage is available using the technique described at http://developer.android.com/guide/topics/data/data-storage.html#filesExternal. However, althoug the files are created succesfully on the device (I can browse them and open them using the device's File Explorer - they are fine), when I connect the device to a Windows XP computer none of the directories or files I created appear and the size of their parent files suggest they do not exist.

I have tried running over the ADB, checked logcat, tried a (signed) release version and even written a second test application which just creates a folder (this behaves the same, ie it creates the folder but this is not visible in Windows Explorer) - nothing anywhere gives me any suggestion as to what the problem might be. If anyone has heard of this before or has any ideas as to what else | could try to fix it please get in touch! We do not have any other devices to test on at the moment, although I hope to remedy this soon, customer permitting.
fpdiver
Freshman
Freshman
 
Posts: 2
Joined: Thu May 27, 2010 2:32 pm

Top

Re: Invisible files on Archos 5 device

Postby fpdiver » Fri May 28, 2010 11:13 am

I have been able to work round this problem by downloading drivers from here (http://www.fs-driver.org/) which allow me to connect in Mass Storage Device mode rather than Media Transfer mode. I can read and copy my files in this mode. It has been suggested that the Media Transfer mode only sees media files, though I am sceptical about this.
fpdiver
Freshman
Freshman
 
Posts: 2
Joined: Thu May 27, 2010 2:32 pm

Top

Return to Other Coding-Problems

Who is online

Users browsing this forum: Exabot [Bot] and 14 guests