How to develop common app for Android 1.5 and above versions

Put your problem here if it does not fit any of the other categories.

How to develop common app for Android 1.5 and above versions

Postby kevindorson » Tue Jun 22, 2010 6:20 pm

Hi All,
I'm still not clear on how to develop a common application code keeping in mind of Android 1.5, and the Android 1.6 and above.
When i started the project, i had set minSDKVersion = 4 which the SDK helped in creating the complete folder structure for DPI, MDPI and HDPI .
Now when i wanted my app to also support Android 1.5, I'm unable to port it. If i change the manifest file as minSDKVersion=3, the entire LDPI,MDPI and HDPI related folders throws Error and does not understand these files.
What i understand is we can generate 4 apk files using the split.density= true in file. Will this help???
What is the right approach i should follow???
Should i generate three different ldpi,mdpi,hdpi apk file from this existing one and create another new project containing a default apk file(compaitibility mode already set as 1.5 version)

Currently the error message what i get is "ERROR: Application requires API version 4. Device API version is 3 (Android 1.5)."
Need assistance!!
Posts: 44
Joined: Mon Mar 29, 2010 11:51 am


Re: How to develop common app for Android 1.5 and above vers

Postby nicholas.hauschild » Wed Jun 23, 2010 2:34 am

Please don't post the same question in multiple categories. Pick the most appropriate and put it there.

Master Developer
Master Developer
Posts: 310
Joined: Fri Dec 04, 2009 4:50 am


Return to Other Coding-Problems

Who is online

Users browsing this forum: No registered users and 24 guests