Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /www/htdocs/w006661d/anddev/includes/utf/utf_tools.php on line 1781
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1781)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1781)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1781)

Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /www/htdocs/w006661d/anddev/includes/utf/utf_tools.php on line 1781

Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /www/htdocs/w006661d/anddev/includes/utf/utf_tools.php on line 1781

Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /www/htdocs/w006661d/anddev/includes/utf/utf_tools.php on line 1781
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4362: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1781)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4364: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1781)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4365: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1781)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4366: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1781)
anddev.org • View topic - EngineOptions setup seems weird to me

EngineOptions setup seems weird to me

Put your problem here if it does not fit any of the other categories.

EngineOptions setup seems weird to me

Postby wu7jian » Thu Jul 25, 2013 4:08 pm

Code: Select all
public EngineOptions onCreateEngineOptions() {
      FillResolutionPolicy EngineFillResolutionPolicy = new FillResolutionPolicy(){
         @Override
         public void onMeasure(final IResolutionPolicy.Callback pResolutionPolicyCallback,final int pWidthMeasureSpec,final int pHeightMeasureSpec){
            super.onMeasure(pResolutionPolicyCallback, pWidthMeasureSpec, pHeightMeasureSpec);
            
            final int measuredWidth  = MeasureSpec.getSize(pWidthMeasureSpec);
            final int measuredHeight = MeasureSpec.getSize(pHeightMeasureSpec);

........then
Code: Select all
EngineOptions engineOptions = new EngineOptions(true,ScreenOrientation.LANDSCAPE_SENSOR,EngineFillResolutionPolicy,mCamera);

I got a weird measurement,with measuredWidth actually smaller than measuredHeight in LANDSCAPE mode,what's the matter with this problem if this is a problem...
wu7jian
Once Poster
Once Poster
 
Posts: 1
Joined: Thu Jul 25, 2013 4:02 pm

Top

Return to Other Coding-Problems

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 13 guests