Eclipse Extremely Slow

Put your problem here if it does not fit any of the other categories.

Eclipse Extremely Slow

Postby TheBigCheese » Thu Nov 26, 2009 2:38 am

Hey, I've just started learning the SDK for Android. Whenever I use Eclipse with Android SDK development, Eclipse becomes extremely laggy, taking 1-2 seconds to flip between certain windows. At one point it took about 3 seconds for any key I typed to be entered into the code. The strange part is that it only happens with Android. Normal Java works perfectly fast.

Is this a common problem? I have a fairly high spec computer (Quad Core 2.8Ghz, 4GB RAM), so I don't think I'm running out of resources. Any help?
User avatar
TheBigCheese
Developer
Developer
 
Posts: 26
Joined: Thu Nov 26, 2009 2:31 am

Top

Re: Eclipse Extremely Slow

Postby TheBigCheese » Thu Nov 26, 2009 5:09 pm

Just in case someone else has this problem too, I fixed it by increasing the memory allocated to Eclipse.

You have to edit eclipse.ini in the installation directory and change the line

Code: Select all
-Xmx512m


to

Code: Select all
-Xmx1024m


Or possibly if it's set lower that 512 (256), bump it up to 512. So far no problems. Make sure you have enough RAM if you do try this though, you should have at least 2GB, probably much safer with 4GB.
User avatar
TheBigCheese
Developer
Developer
 
Posts: 26
Joined: Thu Nov 26, 2009 2:31 am

Top

Return to Other Coding-Problems

Who is online

Users browsing this forum: MSNbot Media and 13 guests