deploying on G1 :(

Put your problem here if it does not fit any of the other categories.

deploying on G1 :(

Postby darolla » Fri Dec 05, 2008 3:44 pm

dear reader ;)

I've got a stupid problem.

I'd like to test my .apk on my boss' G1.

the 1st version never seems to be a problem:

1) "export unsigned application package"
2) keytool -genkey -v -keystore my-release-key.keystore -alias alias_name -keyalg RSA -validity 10000
3) jarsigner -verbose -keystore my-release-key.keystore my_application.apk alias_name
4) deploy on webserver, write email with URL to my boss' gmail
5) boss downloads the .apk with his G1

but now comes the strange part.

after I've fixed some bugs I'd like to deploy another version.

0) increment android:versionCode="5" and android:versionName="5.5.5"
1)..5) same procedure

but the deploy fails.

the only solution I've found yet is to change my packages of all source codes

this way android thinks it is new apk and installs it nicely.

the other way is to connect the G1 with a Windows PC via USB (we are using Linux here) and use adb or eclipse to uninstall the old apk.

what can I do to deploy continuously?

greetings,
marco
User avatar
darolla
Master Developer
Master Developer
 
Posts: 273
Joined: Thu Sep 25, 2008 5:16 pm
Location: Dortmund, Germany

Top

Postby xMemphisx » Mon Dec 08, 2008 10:11 am

As far as deploying continuously goes, the only thing that i can think of that might be causing a problem is if you are signing the new apk with a different key than you were using for the previous version of the apk.

If it helps, because the previous didn't, you can also remove apps from the g1 under Settings > Applications > Manage Applications then uninstall it that way. I hope this helped a little :)
xMemphisx
Developer
Developer
 
Posts: 27
Joined: Wed Jun 25, 2008 12:02 am

Re: deploying on G1 :(

Postby Sparkletron » Fri Dec 12, 2008 5:53 am

I'm also experiencing this problem. The reason given is...

Package [my.package] signatures do not match the previously installed version; ignoring!

So the problem is very likely with how we're signing the jar.
Sparkletron
Developer
Developer
 
Posts: 26
Joined: Tue Nov 04, 2008 6:17 am

Top

Return to Other Coding-Problems

Who is online

Users browsing this forum: No registered users and 12 guests