Android development under ECLIPSE

Put your problem here if it does not fit any of the other categories.

Android development under ECLIPSE

Postby bluef » Thu Jan 07, 2010 11:58 am

Hello,

I have a strange behaviour of my Eclipse IDE...

When I try to launch the application (button RUN), it tells me that the project contains errors to fix... But, I opened every single file of the project, and I did not find any error !

I've try to clean bluid, regenereate the R.java, etc... Nothing...

Do you have an idea ?
Do you know how I can ask to Eclipse to focus me on the error ???

Thank you in advance for your help !

Regards,
Nek
bluef
Developer
Developer
 
Posts: 33
Joined: Thu Nov 19, 2009 9:45 am

Top

Postby wirelessdesigns » Thu Jan 07, 2010 5:25 pm

Nek -

The error is probably project level (like an error in the build path, etc.), and not in a source file. Is the project name the only icon with the red "X" over it in the package explorer?

By default, the Eclipse tab group (where the console, etc. are located) should have a tab named "Problems". This tab will list any warnings or errors for all your projects in the workspace. Is there anything listed for the project you are having issues with? This should also tell you more specifically what the error is.

Depending on the actual error, sometimes project level errors can be automatically cleaned up by making a simple edit to a source file (like adding a line) and saving it again. Especially if your project was able to build and run at some point prior.
wirelessdesigns
Developer
Developer
 
Posts: 25
Joined: Fri Dec 18, 2009 3:27 pm
Location: Littleton, CO

Postby bluef » Fri Jan 08, 2010 5:04 pm

Thank you for your reply.

I found a solution: I restored a working version and started my changes again. I should have done something wrong but what...

Thank you any way !

Nek.
bluef
Developer
Developer
 
Posts: 33
Joined: Thu Nov 19, 2009 9:45 am

Top

Return to Other Coding-Problems

Who is online

Users browsing this forum: No registered users and 18 guests