SDK 1.6???

News, information, contests and special event announcements from members of the anddev.org community.

Update my applications to 1.6 now or wait?

Poll ended at Mon Oct 12, 2009 7:40 pm

Wait
3
43%
Update Now
4
57%
 
Total votes : 7

SDK 1.6???

Postby NevinM » Mon Oct 12, 2009 7:40 pm

So on the weekend I got a notice from the market to upgrade my applications to sdk 1.6. But since there are no phones currently running on this software version (I know the Tattoo is coming). I think that it would be not very smart to change my minimum OS version to version 4 at this time. I think that it would be best to wait until later this fall or to the spring. I have tested my applications on the 1.6 emulator and they work fine, but is there any other advantage to building with 1.6 at this time? I would like to here others thoughts on this.
NevinM
Developer
Developer
 
Posts: 36
Joined: Wed Oct 01, 2008 4:24 am
Location: Lethbridge, Canada

Top

Postby padde » Mon Oct 12, 2009 10:15 pm

I voted for do it now!
The reason is simple. The new sdk brings new realy cool features which can enrich almost
every application. If you dont want to use these features you should at least cross check
your apps with 1.6 to make sure they work properly. Thats by far more important than use
1.6 as minsdk. Building an app right now that NEEDS 1.6 and cant run on older versions is
maybe a bit to early.. i guess most people will run 1.6 late this year or early next. But i could
also be complete off the mark with my assumption.. its hard to tell if android running phones
are used by "normal" people or just by developers and "geeks".. the latter will update to 1.6
as soon as they can :)

Personally i cant wait to get the update and i check almost every hour whether the OTA finally arrived :D
padde
Master Developer
Master Developer
 
Posts: 443
Joined: Wed Apr 08, 2009 4:52 pm

Top

Return to Open News

Who is online

Users browsing this forum: No registered users and 3 guests