How to speed up the emulator?

Basic Tutorials concerning: GUI, Views, Activites, XML, Layouts, Intents, ...

How to speed up the emulator?

Postby minhzc » Sun Aug 02, 2009 3:11 pm

Each time I debug the program, the emulator starts from booting and it takes too much time...
If I don't close the emulator, it also takes the same time to run the application.
Is there anyway to solve this problem?
thank you.
minhzc
Freshman
Freshman
 
Posts: 8
Joined: Sun Aug 02, 2009 10:26 am
Location: Vietnam

Top

Postby TheChosen » Mon Aug 03, 2009 11:27 am

The command line argument -no-boot-anim disables the boot animation. This makes the startup a bit faster.
TheChosen
Experienced Developer
Experienced Developer
 
Posts: 62
Joined: Tue Jan 06, 2009 7:18 pm
Location: Germany

Postby YongPang » Mon Aug 03, 2009 3:40 pm

I have the same question,Thanks!
YongPang
Once Poster
Once Poster
 
Posts: 1
Joined: Mon Aug 03, 2009 3:25 pm

Postby minhzc » Wed Aug 05, 2009 5:36 am

TheChosen wrote:The command line argument -no-boot-anim disables the boot animation. This makes the startup a bit faster.


where to run this command?
I use windows Vista and Cygwin
minhzc
Freshman
Freshman
 
Posts: 8
Joined: Sun Aug 02, 2009 10:26 am
Location: Vietnam

Postby TheChosen » Wed Aug 05, 2009 11:04 am

How do you run the emulator? If you run it from command line, just add the string at the end. If you run it from within an IDE, you should be able to give command line arguments in the run configuration.
TheChosen
Experienced Developer
Experienced Developer
 
Posts: 62
Joined: Tue Jan 06, 2009 7:18 pm
Location: Germany

Postby tbruyelle » Mon Sep 07, 2009 9:44 am

You need to start the emulator only one time, do you know that ?

After that, when you change your app code, just do "Run->Debug History->Your App" and your app will be reinstalled and restarted in the emulator.
No need to close/restart.

HTH
Tom
tbruyelle
Junior Developer
Junior Developer
 
Posts: 11
Joined: Mon Sep 07, 2009 6:45 am

Top

Postby konic » Tue Sep 08, 2009 4:56 pm

tbruyelle wrote:You need to start the emulator only one time, do you know that ?

Well, there is more. Somebody already posted it here, I tried, and it worked:
1. Find 'emulator.exe' file, - it's in 'tools' folder.
2. Right click on it and select 'Properties'.
3. Select 'Compatibility' tab.
4. Check the box 'Run this program...'
5. Choose 'Windows 98/Me', even if you are on Windows XP.

This definitely speeds up loading emulator :)
konic
Developer
Developer
 
Posts: 32
Joined: Mon Aug 24, 2009 3:16 pm

Top

Return to Novice Tutorials

Who is online

Users browsing this forum: No registered users and 6 guests