Emulating a SD-Card

Basic Tutorials concerning: GUI, Views, Activites, XML, Layouts, Intents, ...

Postby cadlg » Mon Mar 03, 2008 3:47 pm

If your problem is in fact due to a "-wipe-data", all data would be cleared every time you run your application, not only when you restart eclipse.

If that's the case, in the eclipse menu, go to Run-Open Run Dialog-Target and check the text box below "Additional Emulator Command Line Options". If there is a "-wipe-data" there, remove it.
cadlg
Experienced Developer
Experienced Developer
 
Posts: 84
Joined: Wed Feb 20, 2008 12:33 am
Location: Guatemala

Top

Postby snowtiger » Mon Mar 03, 2008 4:16 pm

Are you sure, that -wipe-data deletes sdcard, too?

Where/how did u push your images? Like this: "adb push image1.jpg sdcard/image1.jpg" ?
snowtiger
Developer
Developer
 
Posts: 34
Joined: Fri Dec 21, 2007 10:44 am

Postby bavarol » Sun Mar 09, 2008 2:38 pm

snowtiger wrote:Are you sure, that -wipe-data deletes sdcard, too?

Where/how did u push your images? Like this: "adb push image1.jpg /sdcard/image1.jpg" ?

Hi Snowtiger, you have forgotten a backslash, if you created sd-card correct, you should be able to do "adb push ..." now.

Regards
bavarol
Experienced Developer
Experienced Developer
 
Posts: 52
Joined: Mon Dec 10, 2007 9:19 pm

Postby snowtiger » Mon Mar 10, 2008 10:21 am

First, I didn't have any problems with my sdcard :)

Second, you don't need that first backslash (at least with windows)
snowtiger
Developer
Developer
 
Posts: 34
Joined: Fri Dec 21, 2007 10:44 am

Postby Archana » Tue May 13, 2008 1:09 pm

Hi plusminus,

I created sdcard image and push it to emulator,but i dont know how to view those images,can u please tell me.
Thanks,
Archana.
Archana
Archana
Experienced Developer
Experienced Developer
 
Posts: 53
Joined: Thu Feb 28, 2008 12:00 pm
Location: Bangalore

problem with push

Postby rohan » Thu Jun 26, 2008 5:22 pm

Hi ,
I hav tried this tutorial and hav created a sdcard...but i am not able to push data into the card........the cmd that i hav written...

"adb push E:\rohan\mcs\android\android-sdk_m5-rc14_windows\docs\images\android_adc.gif E:\rohan\mcs\android\mycard\android_adc.gif"

Its giving "no device error"
Plz help me

Thanks
rohan
Developer
Developer
 
Posts: 34
Joined: Wed Mar 19, 2008 2:26 pm

Top

Re: problem with push

Postby ych.tiger » Wed Jul 30, 2008 8:52 am

rohan wrote:Hi ,
I hav tried this tutorial and hav created a sdcard...but i am not able to push data into the card........the cmd that i hav written...

"adb push E:rohanmcsandroidandroid-sdk_m5-rc14_windowsdocsimagesandroid_adc.gif E:rohanmcsandroidmycardandroid_adc.gif"

Its giving "no device error"
Plz help me

Thanks


I think you must run emulator first.
User avatar
ych.tiger
Junior Developer
Junior Developer
 
Posts: 14
Joined: Tue Jul 08, 2008 4:07 am
Location: China

Postby saahil » Sun Aug 24, 2008 7:28 pm

making the image file worked perfect for me, except for the part where i've to push a file onto the image. for that i pasted the file first into the same folder as the sdcard image file and then used the command

Code: Select all
adb push evenFlow.mp3 /sdcard/evenFlow.mp3


i get the following error -

Code: Select all
failed to copy evenFlow.mp3 to /sdcard/evenFlow.mp3 : Read Only file system


your help is highly looked forward to....
Saahil
<think><code></code>.......
saahil
Freshman
Freshman
 
Posts: 5
Joined: Sun Aug 24, 2008 6:42 pm
Location: Manipal, Karnataka, India

Hi Thanks, It's working for me

Postby infotomrk » Thu Oct 16, 2008 10:32 am

Hi Thanks javascript:emoticon(':D'), It's working for me...

Initially misunderstand javascript:emoticon(':?'), Finally it's working javascript:emoticon(':!:') as per the flash demo. javascript:emoticon(':idea:') .. It's really clear only and v.simple...javascript:emoticon(':shock:')

Thanks javascript:emoticon(':D') once again...
javascript:emoticon(':arrow:')
MRK Think BIG
infotomrk
Freshman
Freshman
 
Posts: 3
Joined: Fri Sep 12, 2008 3:59 pm
Location: India

Postby asifk1234 » Tue Nov 18, 2008 12:29 pm

Hi +-;

I am also receiving same error as that of saahil(abover).
Please reply as soon as possible.

Thanks in advance.
asifk1234
Freshman
Freshman
 
Posts: 5
Joined: Tue Nov 18, 2008 8:14 am

Postby MrSnowflake » Tue Nov 18, 2008 1:58 pm

Did you load the sd with the emulator? If there's no id /sdcard would be ro.
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Postby asifk1234 » Tue Nov 18, 2008 2:23 pm

yes I loaded SDCARD in the emulator as per this tutorial.
/sdcard folder is available in the filebrowser but I cannot push any file.
It shows error :: failed to copy 'C:1.txt' to '/sdcard/asif': Read-only file system.
asifk1234
Freshman
Freshman
 
Posts: 5
Joined: Tue Nov 18, 2008 8:14 am

Postby TheChosen » Thu Jan 08, 2009 1:32 pm

I don't use the adb push command to put files onto the sd card image. Instead, you can use the much more convenient explorer that comes with the dalvik debug management tool (DDBM.bat) in the tools folder. Just start the emulator and wait until the debug tool recognizes it.
TheChosen
Experienced Developer
Experienced Developer
 
Posts: 62
Joined: Tue Jan 06, 2009 7:18 pm
Location: Germany

Postby saurabhchokshi » Wed Feb 04, 2009 1:11 am

Hello,

I cannot find the filebrowser application in my Android Device. Could you please let me know what the problem might be??

[mod]This has nothing to do with emulating an SD card, please post in the correct sub-forum or thread.
saurabhchokshi
Freshman
Freshman
 
Posts: 3
Joined: Wed Feb 04, 2009 1:05 am

Postby Emmanuel7 » Wed Feb 04, 2009 1:57 am

To find the file explorer in eclipse, go to Window / Open Perspective / Others / DDMS
In DDMS, you should have a File Explorer view ( if not, open it in Window / Show View / File Explorer )
Emmanuel7
Senior Developer
Senior Developer
 
Posts: 164
Joined: Fri Dec 12, 2008 2:17 am
Location: Paris

Top
PreviousNext

Return to Novice Tutorials

Who is online

Users browsing this forum: No registered users and 7 guests