A question about android app run on G1 phone

Problems with WiFi, SQLite ,Bluetooth, WiMax, Proxies, etc...

A question about android app run on G1 phone

Postby jianweiw1022 » Tue Feb 24, 2009 4:15 pm

Hello ,i have a question.

I wrote a app which use internet access ,the app can work on emulator ,but when running on G1 phone ,it can not work ,i think it maybe permission issue ,G1 phone should give internet permission to my app ,but i do not know how to .

Can anyone give me a answer.

Thanks a lot!
jianweiw1022
Freshman
Freshman
 
Posts: 6
Joined: Sat Feb 14, 2009 4:27 am

Top

Postby MrSnowflake » Tue Feb 24, 2009 4:20 pm

Permissions work the same on device as on emulator.
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Postby jianweiw1022 » Tue Feb 24, 2009 4:24 pm

Do anyone meet this issue before?

I use android-sdk-windows-1.0_r1 as developement enviroment and a g1 phone as device.

The app can access internet on emulator but can not get expected result on phone?

Too boring :-(
jianweiw1022
Freshman
Freshman
 
Posts: 6
Joined: Sat Feb 14, 2009 4:27 am

Postby MrSnowflake » Tue Feb 24, 2009 4:29 pm

What is the concrete Exception on the emulator?
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Postby jianweiw1022 » Tue Feb 24, 2009 4:33 pm

Seems can work now :-)

I signed it ,wish it is the root cause.

If it is ,can any one tell me why ?
jianweiw1022
Freshman
Freshman
 
Posts: 6
Joined: Sat Feb 14, 2009 4:27 am

Postby MrSnowflake » Tue Feb 24, 2009 4:55 pm

Should not have been te problem for testing, as eclipse signes it with a debug certificate.
User avatar
MrSnowflake
Moderator
Moderator
 
Posts: 1439
Joined: Sat Feb 16, 2008 3:11 pm
Location: Flanders, Belgium

Top

Return to Networking & Database Problems

Who is online

Users browsing this forum: No registered users and 5 guests