Location Provider - Coarse Location Problem

Tutorials that use the MapActivity. Many using GPS functionality.

Location Provider - Coarse Location Problem

Postby LBDev » Fri Jun 26, 2009 1:16 am

The way we are retrieving locations from our Android phones is to 1st get a Coarse Location followed by a Fine Location. This is for the case where the user may be inside a building initially and unable to track satellites. After we get our coarse location we transition to a fine location to track satellites. This method has been working fine for several months. We recently upgraded to 1.5 and our mapping application, to my recollection continued to work.

For the past couple of days we have not been able to get a coarse location and we are receiving a status message in the onStatusChange callback of LocationProvider.TEMPORARILY_UNAVAILABLE. We have re-installed previous versions our code that used 1.1 and we are receiving the same status message of .TEMPORARILY_UNAVAILABLE. Other than the obvious description of the constant, we can find no meaningful information.

Has anybody seen this message?
Are my local towers not providing the required data?
Any thoughts?


Setup:
Using Android G1 phones
Firmware: 1.5, Build# CRB43
Eclipse IDE 3.4.2 – 1700 with latest Android plug-ins
API - Google API (1.5)
LBDev
Freshman
Freshman
 
Posts: 7
Joined: Fri Feb 06, 2009 8:25 pm
Location: Long Beach, Ca

Top

Boo Boo

Postby LBDev » Fri Jun 26, 2009 1:31 am

I erred in putting this query under Map Tutorials. Mods, please remove this post. I have posted this same topic under Map problems.
LBDev
Freshman
Freshman
 
Posts: 7
Joined: Fri Feb 06, 2009 8:25 pm
Location: Long Beach, Ca

Top

Return to Map Tutorials

Who is online

Users browsing this forum: No registered users and 1 guest