problems connecting to android device (windows)

General topics about the Android-Platform itself.
Coding issues please to the subforum right below.

problems connecting to android device (windows)

Postby nikeighley » Mon Aug 27, 2012 11:39 am

sorry if this is the wrong forum for this question, but I couldn't see a more applicable one

I'm having trouble getting the basic "hello world" program to run on my device. Even though its connected via USB running the app seems to run up the emulator. The emulator doesn't seem to do much either.

I'm develping on Windows. When I plug the USB in Windows asks me what action I want to perform, I respond by opening the file explorer.
nikeighley
Freshman
Freshman
 
Posts: 6
Joined: Mon Aug 27, 2012 11:21 am

Top

Re: problems connecting to android device (windows)

Postby nikeighley » Mon Aug 27, 2012 12:55 pm

ok, I stumbled across the console window (I'm using eclipse). It says adb isn't running. If I run adb from a "DOS" window then there are no devices available. From windows I can see my devices file-system I'm guessing I've got the USB connection setup wrong somehow.

2nd attempt at running the app doesn't get an adb error but does launch the emulator.

So any ideas about what I might be doing wrong so that I can't see my device (Galaxy S3)
nikeighley
Freshman
Freshman
 
Posts: 6
Joined: Mon Aug 27, 2012 11:21 am

Re: problems connecting to android device (windows)

Postby nikeighley » Mon Aug 27, 2012 1:00 pm

And after a while (20s) I get an error saying the emulator disconnected. Also the emulator has gained a red border, does that mean something?
nikeighley
Freshman
Freshman
 
Posts: 6
Joined: Mon Aug 27, 2012 11:21 am

Re: problems connecting to android device (windows)

Postby nikeighley » Mon Aug 27, 2012 1:19 pm

good grief. Is it normal for the emulator to take 20 *minutes* to run up?!

this may be the source of my problems with the emulator- I'm simply not giving it long enough.

No one seems to have responded with ideas about my real device...
nikeighley
Freshman
Freshman
 
Posts: 6
Joined: Mon Aug 27, 2012 11:21 am

Re: problems connecting to android device (windows)

Postby nikeighley » Mon Aug 27, 2012 1:21 pm

Kool! :) :)

the baby app just ran on the emulator!
nikeighley
Freshman
Freshman
 
Posts: 6
Joined: Mon Aug 27, 2012 11:21 am

Re: problems connecting to android device (windows)

Postby nikeighley » Mon Aug 27, 2012 3:48 pm

I still can't see my device with
adb devices


:(
nikeighley
Freshman
Freshman
 
Posts: 6
Joined: Mon Aug 27, 2012 11:21 am

Top

Return to General

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests